Nowa instalacja na raspbian stretch lite


Topic author
ryba_ns
Posty: 18
Rejestracja: śr lip 10, 2019 10:49 am
Lokalizacja: Nowa Sarzyna
Postawił piwo: 6 razy

Nowa instalacja na raspbian stretch lite

#1

Post autor: ryba_ns » wt lip 23, 2019 9:30 am

Kod: Zaznacz cały

root@raspberrypi:/var/www# cd nettemp && git checkout betamm && ./install_nettemp
Already on 'betamm'
Your branch is up-to-date with 'origin/betamm'.
Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Hit:3 https://packages.sury.org/php stretch InRelease
Fetched 25.4 kB in 1s (22.7 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.3).
fping is already the newest version (3.15-1).
gcc is already the newest version (4:6.3.0-4).
gcc set to manually installed.
git is already the newest version (1:2.11.0-3+deb9u4).
htop is already the newest version (2.0.2-1).
iptables is already the newest version (1.6.0+snapshot20161117-6).
make is already the newest version (4.1-9.1).
make set to manually installed.
mariadb-client is already the newest version (10.1.38-0+deb9u1).
mc is already the newest version (3:4.8.18-1).
snmp is already the newest version (5.7.3+dfsg-1.7+deb9u1).
socat is already the newest version (1.7.3.1-2+deb9u1).
socat set to manually installed.
sudo is already the newest version (1.8.19p1-2.1).
php7.3-fpm is already the newest version (7.3.7-1+0~20190710.40+debian9~1.gbp032aec).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libssl1.1 : Breaks: lighttpd (< 1.4.49-2) but 1.4.45-1 is to be installed
 mosquitto : Depends: libwebsockets8 (>= 1.6.0) but it is not going to be installed
 mosquitto-clients : Depends: libmosquitto1 (= 1.4.10-3+deb9u4) but it is not going to be installed
 python-dev : Depends: libpython-dev (= 2.7.13-2) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.13-1~) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
[ ok ] packages
[ ok ] 1wire
[ ok ] DHT
[ ok ] GPIO
[ ok ] I2C
[ ok ] FW
[ ok ] SDM120
sed: can't read /etc/apcupsd/apcupsd.conf: No such file or directory
sed: can't read /etc/apcupsd/apcupsd.conf: No such file or directory
sed: can't read /etc/apcupsd/apcupsd.conf: No such file or directory
sed: can't read /etc/default/apcupsd: No such file or directory
sed: can't read /etc/apcupsd/onbattery: No such file or directory
sed: can't read /etc/apcupsd/offbattery: No such file or directory
[ ok ] WWW
[ ok ] Cron
install/db/db.sh: line 3: php-cgi: command not found
[ error ] Services
taka sytuacja... instalator przystosowany do bustera ?
Pozdrawiam Wojtek

WeatherStation ver 1.3 @pimowo, Raspberry Pi 2B +SSD
Awatar użytkownika

pasiekazj
Twórca oprogramowania
Posty: 150
Rejestracja: pn lip 01, 2019 12:08 pm
Otrzymał  piwo: 14 razy
Kontakt:

Re: Nowa instalacja na raspbian stretch lite

#2

Post autor: pasiekazj » wt lip 23, 2019 10:38 am

Tak, przystosowany pod bustera. Przed weekendem instalowałem na buster lite i wszystko śmiga.
Rpi 4 + SSD 240 GB + nettemp.
http://mmblog.pl

Topic author
ryba_ns
Posty: 18
Rejestracja: śr lip 10, 2019 10:49 am
Lokalizacja: Nowa Sarzyna
Postawił piwo: 6 razy

Re: Nowa instalacja na raspbian stretch lite

#3

Post autor: ryba_ns » śr lip 24, 2019 9:35 am

potwierdzam na czystym Busterze poszło...
Pozdrawiam Wojtek

WeatherStation ver 1.3 @pimowo, Raspberry Pi 2B +SSD

swiezak
beta tester
Posty: 29
Rejestracja: ndz cze 30, 2019 10:10 pm
Postawił piwo: 6 razy
Otrzymał  piwo: 1 raz

Re: Nowa instalacja na raspbian stretch lite

#4

Post autor: swiezak » czw sie 15, 2019 9:25 pm

Proszę o weryfikację- u mnie po nowej instalacji na buster nie mogę wyłączyć www authmod- pomimo odznaczenia opcji (suwak na off) nadal wyskakuje monit o zalogowanie się

wicio1984
Posty: 15
Rejestracja: sob lip 13, 2019 9:24 pm

Re: Nowa instalacja na raspbian stretch lite

#5

Post autor: wicio1984 » czw sie 15, 2019 9:31 pm

swiezak pisze:Proszę o weryfikację- u mnie po nowej instalacji na buster nie mogę wyłączyć www authmod- pomimo odznaczenia opcji (suwak na off) nadal wyskakuje monit o zalogowanie się
Mam to samo.

Wysłane z mojego Redmi Note 4 przy użyciu Tapatalka

Awatar użytkownika

pasiekazj
Twórca oprogramowania
Posty: 150
Rejestracja: pn lip 01, 2019 12:08 pm
Otrzymał  piwo: 14 razy
Kontakt:

Re: Nowa instalacja na raspbian stretch lite

#6

Post autor: pasiekazj » pn sie 19, 2019 8:48 am

wicio1984 pisze:
czw sie 15, 2019 9:31 pm
swiezak pisze:Proszę o weryfikację- u mnie po nowej instalacji na buster nie mogę wyłączyć www authmod- pomimo odznaczenia opcji (suwak na off) nadal wyskakuje monit o zalogowanie się
Mam to samo.

Wysłane z mojego Redmi Note 4 przy użyciu Tapatalka
a co się dzieje jeśli z konsoli dasz :

Kod: Zaznacz cały


sudo lighttpd-disable-mod auth
sudo service lighttpd restart

Rpi 4 + SSD 240 GB + nettemp.
http://mmblog.pl

swiezak
beta tester
Posty: 29
Rejestracja: ndz cze 30, 2019 10:10 pm
Postawił piwo: 6 razy
Otrzymał  piwo: 1 raz

Re: Nowa instalacja na raspbian stretch lite

#7

Post autor: swiezak » pn sie 19, 2019 5:37 pm

sudo lighttpd-disable-mod auth
already disabled auth

restart i niestety nadal to samo,
w wolnej chwili podesle dane do wejscia

maciejka512
Posty: 3
Rejestracja: pn wrz 23, 2019 10:44 am

Re: Nowa instalacja na raspbian stretch lite

#8

Post autor: maciejka512 » pt wrz 27, 2019 12:39 pm

instalacja betamm nie działa na swiezym systemie Strech na RPI 3B+:

Kod: Zaznacz cały

root@raspberrypi:/var/www# apt-get update && apt-get install -y git
Stary:1 http://archive.raspberrypi.org/debian stretch InRelease
Pobieranie:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15,0 kB]
Pobieranie:3 http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages [11,7 MB]
Pobrano 11,7 MB w 12s (951 kB/s)                                                                       
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
git is already the newest version (1:2.11.0-3+deb9u4).
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
root@raspberrypi:/var/www# git clone https://github.com/mariano78/nettemp
Cloning into 'nettemp'...
remote: Enumerating objects: 133, done.
remote: Counting objects: 100% (133/133), done.
remote: Compressing objects: 100% (100/100), done.
remote: Total 30955 (delta 73), reused 67 (delta 33), pack-reused 30822
Receiving objects: 100% (30955/30955), 8.05 MiB | 3.28 MiB/s, done.
Resolving deltas: 100% (21832/21832), done.
root@raspberrypi:/var/www# cd nettemp && git checkout betamm && ./install_nettemp
Already on 'betamm'
Your branch is up-to-date with 'origin/betamm'.
Stary:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Stary:2 http://archive.raspberrypi.org/debian stretch InRelease
Czytanie list pakietów... Gotowe
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
E: Nie udało się odnaleźć pakietu php7.3-cgi
E: Couldn't find any package by glob 'php7.3-cgi'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-cgi"
E: Nie udało się odnaleźć pakietu php7.3-sqlite3
E: Couldn't find any package by glob 'php7.3-sqlite3'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-sqlite3"
E: Nie udało się odnaleźć pakietu php7.3-fpm
E: Couldn't find any package by glob 'php7.3-fpm'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-fpm"
E: Nie udało się odnaleźć pakietu php7.3-curl
E: Couldn't find any package by glob 'php7.3-curl'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-curl"
E: Nie udało się odnaleźć pakietu php7.3-mysql
E: Couldn't find any package by glob 'php7.3-mysql'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-mysql"
E: Nie udało się odnaleźć pakietu php7.3-snmp
E: Couldn't find any package by glob 'php7.3-snmp'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-snmp"
E: Nie udało się odnaleźć pakietu php7.3-xml
E: Couldn't find any package by glob 'php7.3-xml'
E: Nie udało się znaleźć żadnego pakietu według wyrażenia regularnego "php7.3-xml"
[ ok ] packages
[ ok ] 1wire
[ ok ] Python - Adafruit
[ ok ] DHT
[ ok ] GPIO
[ ok ] I2C
[ ok ] FW
[ ok ] SDM120
sed: nie można odczytać /etc/apcupsd/apcupsd.conf: Nie ma takiego pliku ani katalogu
sed: nie można odczytać /etc/apcupsd/apcupsd.conf: Nie ma takiego pliku ani katalogu
sed: nie można odczytać /etc/apcupsd/apcupsd.conf: Nie ma takiego pliku ani katalogu
sed: nie można odczytać /etc/default/apcupsd: Nie ma takiego pliku ani katalogu
sed: nie można odczytać /etc/apcupsd/onbattery: Nie ma takiego pliku ani katalogu
sed: nie można odczytać /etc/apcupsd/offbattery: Nie ma takiego pliku ani katalogu
[ ok ] WWW
[ ok ] Cron
install/db/db.sh: linia 3: php-cgi: nie znaleziono polecenia
[ error ] Services
Awatar użytkownika

pasiekazj
Twórca oprogramowania
Posty: 150
Rejestracja: pn lip 01, 2019 12:08 pm
Otrzymał  piwo: 14 razy
Kontakt:

Re: Nowa instalacja na raspbian stretch lite

#9

Post autor: pasiekazj » pt wrz 27, 2019 1:39 pm

@maciejka512 kilka postów wyżej jest napisane, że instalator przystosowany jest do bustera
Rpi 4 + SSD 240 GB + nettemp.
http://mmblog.pl

maciejka512
Posty: 3
Rejestracja: pn wrz 23, 2019 10:44 am

Re: Nowa instalacja na raspbian stretch lite

#10

Post autor: maciejka512 » pt wrz 27, 2019 3:15 pm

ok, to jak mam zainstalować wersję beta lub betamm na Strech'u?
Musi być Strech bo Kodi nie jest jeszcze zoptymalizowane na bustera i nie śmiga na 3b+

Ari93
Posty: 17
Rejestracja: pt sie 16, 2019 8:41 am
Postawił piwo: 1 raz

Re: Nowa instalacja na raspbian stretch lite

#11

Post autor: Ari93 » sob wrz 28, 2019 1:01 am

Zainstaluj sobie starszą wersje z gita np z 17.07 i powinno być ok jak póki co nie będziesz aktualizował. Wydaje mi się że komendą
sudo git checkout c62b22bcd4411a5fc7138a45afabb7ad052861fd
powinno się udać ale już dłuższą chwilę nie korzystałem z gita.

maciejka512
Posty: 3
Rejestracja: pn wrz 23, 2019 10:44 am

Re: Nowa instalacja na raspbian stretch lite

#12

Post autor: maciejka512 » czw paź 10, 2019 9:59 pm

dzięki za podpowiedź @Ari93 !
Jak ktoś chciałby jeszcze używać betemm na Strechu to z tego co udało mi się ustalić w praktyce to jest ostatnia dziajaca instalacja ze strechem- rewizja: 393f04648914e2b6fd554ad769134b59807b759d

Użyłem poniższych komend i wszystko poszło i narazie działa dobrze:
root# git checkout 393f04648914e2b6fd554ad769134b59807b759d
root# git reset --hard
root# ./install_nettemp
ODPOWIEDZ